Home
News
rFactor 2
rFactor 1
Forums
Contact
Company
Technology
Image Space Inc. YouTube rFactor 2 Twitter Image Space Inc. Google Plus rFactor 2 Facebook
Tracks
Try or Buy rFactor 2
$43.99/84.99 Windows Only PCDL
Download rFactor 2 Demo Now!

NOTICE Notice: This is an old thread and information may be out of date. The last post was 1109 days ago. Please consider making a new thread.
Results 1 to 13 of 13

Thread: Vehicle Collision mismatch

  1. #1
    Frank Geyer's Avatar

     PC Specification 

    Registered
    Oct 2010
    Location
    Germany

    Vehicle Collision mismatch

    Hi there everybody,

    just simple and straight forward:

    Under which circumstances throws rFactor the exception Driver Name "Vehicle Collision" mismatch like in the following ...?

    Code:
    <Chat et="3.5">Driver Name "Vehicle Collision" mismatch</Chat>
    <Sent et="3.5">Driver Name "Vehicle Collision" mismatch</Sent>
    <Chat et="3.5">Driver Name was removed from the game: Mismatch Detected</Chat>
    <Chat et="3.7">Driver Name left the game.</Chat>
    Is there only one or are there many? Is there a way to prevent this depending on the circumstances?

    Thank you very much in advance!

    Cheers
    Frank

  2. #2
    LesiU's Avatar

     rFactor 2 Validated PC Specification Where I race Modding Group: SimRacingPL 

    Registered
    Oct 2010
    Location
    Poland
    First, make sure that guy has all neccesary mods, tracks and patches that are installed on the server. If he has, then check mod gen files, looking for lines with references to nonexisting gmt files.
    For example, he set gfx details to full, but if in gen file, for <LOW> there is a reference to non existing gmt file, he will have that "Vehicle Collision" mismatch. I had such issue not that long ago and it took me a good few hours to figure out, what was causing it
    If that's not it, then you can nail it down by doing this:
    Launch a dedicated server on your PC and connect to it with each car of the mod. Because "Vehicle Collision" mismatch sometimes won't show just after you have connected to server, you have to switch the session to see if particular car is ok or not. I strongly suggest you to just switch to the race session. Then, you will be 100% sure (with mismatch, by default, you will be kicked from the race).
    Once you figured out, which car(s) is/are having issues, check all its/their files if they are ok. See if veh file contain proper file names. The same with hdv. Check for unclosed instances in gen file, just in case.

    I hope that helps.
    Last edited by LesiU; 03-26-11 at 07:47 AM.

  3. #3
    Frank Geyer's Avatar

     PC Specification 

    Registered
    Oct 2010
    Location
    Germany
    Hi LesiU,

    it is always a pleasure to read your replies !!! Your explanations helps a lot. I will get back with our Modder to go through all this and will get back to you as soon as we hit the flaw ... but this could take a little while !!!

    Thanks again!

    Cheers
    Frank

  4. #4
    lordpantsington's Avatar

     rFactor 2 Validated PC Specification 

    Registered
    Oct 2010
    Location
    Grand Rapids, MI
    More often then not VC mismatches are caused by the client using a VEH file the server does not have.

  5. #5
    Frank Geyer's Avatar

     PC Specification 

    Registered
    Oct 2010
    Location
    Germany
    Hi lordpantsington,

    thank you for your reply! I am going to cross check this too, cause this seems to be pretty easy to check.

    Cheers
    Frank

  6. #6
    LesiU's Avatar

     rFactor 2 Validated PC Specification Where I race Modding Group: SimRacingPL 

    Registered
    Oct 2010
    Location
    Poland
    EDIT: Nevermind
    Last edited by LesiU; 03-26-11 at 06:26 PM.

  7. #7
    Frank Geyer's Avatar

     PC Specification 

    Registered
    Oct 2010
    Location
    Germany
    So guys ... it's been quite a while but finally I am able to report back some successful debugging.

    You're both right! And all the issues mentioned above helped me a lot!

    What has happened to our environment was, that people where changing e.g. the GenString-Value within the .veh file of their car to meet their personal needs after a synchronization process of the whole mod. The dangerous thingy about this is, that in some cases this works like a ticking time bomb cause it isn't reported while joining the server or hitting the race button rather than during a driver swap rFactor detects that something is wrong and goes into action. So in the case of very strict server settings one will be kicked immediately and the race is over.

    The whole situation on that is even worse, cause the same manually changed settings within a .veh file on two fully rFactor mod synced but physical different systems behave differently.

    At least this is what I came up with.

    OK thanks again for your help guys.

    Cheers
    Frank

  8. #8
    Jouni's Avatar

     PC Specification 

    Newer Member
    Oct 2010
    Location
    Vantaa, Finland
    We´ve been getting a lot of "vehicle collision" mismatches the past 2 weeks, they seem pretty much random, as we tryed different mods and get them there too.
    Its started to look like our server has something wrong but cant figure it out what it is. As i fired up my rig as server with same mod (same drivers) we didnt get the VC mismatches.
    The VC mismatches only showed when changing session over. (league server)
    Reading posts here, i get the impression that it cant be a server issue. Whats the Gen-sting-value all about?
    Help please.
    Last edited by Jouni; 07-13-11 at 07:42 PM. Reason: added info.
    Uphold Gentlemen driver standards. Police yourself!

  9. #9
    Frank Geyer's Avatar

     PC Specification 

    Registered
    Oct 2010
    Location
    Germany
    Hi Jouni,

    it turns out that if the files doesn't match (remote rF DS >>> local client and/or vice versa) internally validated by a checksum, the server throws a MISMATCH ... so you will have most likely different files on your local machine compared to the files on your remote server which hosts the rF DS ...

    Currently I have a Sync-Tool in a development queue which synchronizes a mod directory by means of comparing the file's checksum with an additional LAST MODIFIED DATE alignment ... if you don't mind and in case your environment is sufficient !?!? I would like to give you a hand on solving your problems while you provide yourself as a beta tester ...

    Cheers
    Frank

  10. #10
    Jouni's Avatar

     PC Specification 

    Newer Member
    Oct 2010
    Location
    Vantaa, Finland
    Hi Frank,
    thanks for coming forward to help us out, much apreachiated.
    I just cant understand how its possable that it works on my rig (as server) but not on the dedicated one. Its from my rig that the files have been uploaded to the server to begin with. Ive now doubled checked them, over right from my rig again.
    And now, it dosnt matter what mod i put up on the dedi server, it mismatches everyone of them when we move to the next session. Up till now, all these mods, (Historix, Caterham, DRM and CSGT) have worked fine, nothing has been done to them, and now we´re getting VC mismatches with them all.
    In these mods, only Caterhams are the ones we use skins, other mods are basic mod dl´s, we dont accept "standalone" vehicle files for cars in any of our mods, skins are fine, ok, but i refuse to upload any new vehicle files for "standalone" cars to our server.
    I understand, if someone has made a standalone car, he will and should get a VC mismatch, but the odd thing is, everyones getting VC mismatches, including me.

    Well, im on summer vacation, so im fine in testing out your new tool. Im not good at PC tech´s, so you will have to be patient with an old fart. (56y)
    Uphold Gentlemen driver standards. Police yourself!

  11. #11
    Frank Geyer's Avatar

     PC Specification 

    Registered
    Oct 2010
    Location
    Germany
    Hi Jouni,

    first of all ... age ain't nothing but a number !!! ... and no problem, u're welcome.

    What you can do up front is to clarify if those reported files are really the same, local and remote by using a command line tool like this: MD5. It isn't really hard to use.

    What can happen during an ftp exchange, if the mod files were deployed by ftp, that files are being transferred in the wrong mode (ASCII | BINARY) or they get corrupted while being transferred for whatever kind of reason. Another approach might be that the file system on your server got corrupted ... !?!? Use CHKDSK at the command prompt to verify the file system is still ok !!! Type CHKDSK /? For getting help on this utility ...

    I don't know if can make it today, so we need to setup an appointment so we can investigate what is going on u're site ...

    Cheers
    Frank

  12. #12
    MaXyM's Avatar

     rFactor 2 Validated PC Specification Facebook profile @@MaXyM_SRPL 

    Registered
    Oct 2010
    Location
    Prague / CR
    Issue with missmatches appearing just after session change is related to bad references to gmt files.
    Check your gen files. Look out for gmts assigned to levels of details you are not using. Probably you are refering to gmt which doesn't exist (for example by mistyping).

    You can check if I'm right, by setting gfx to details different than you ussualy use. After that connect to dedicated server and change a session.

  13. #13
    Jouni's Avatar

     PC Specification 

    Newer Member
    Oct 2010
    Location
    Vantaa, Finland
    We just finished our friday night league races and the server run just fine. Emailed alot with our server guy, mainly he said he didnt do anything big to it, but this morning it started working just fine and no more mismatches.
    It remains a mistery to us on what it was causing it, so cant help on that.

    anyway, all mods was VC mismatching that we tested during the 2 weeks of mismatches. Last night, i was alone on the server and getting VCmis. I only delated the track Hat files and all replays, plus fixed 2 track files that hade not uploaded correctly.
    During this 2 weeks of problems, it was very difficult to upload tracks and mods to the server. Only when i delated some not used tracks and mods it would let me upload. Server guy said theres no limit to files on the server as i suspected.
    anyway, he sent me an email : "The server may be enforcing consistency on all files, I will investigate this matter for you later this evening"
    In the morning he sent again: "Im unable to find any issues with the servers configuration at present Jouni"
    This morning i got it working, although it was set to ISI´s default mod "SR .. whatever" I couldnt get it changed to the mod we needed for this evening (Caterham) but after a lot of tinkering and restarts it finaly changed and i tested it on a few mods and the VCmismatches was away and gone.
    Sent the server guy an email that it seems to be working but will test more with guys that can join in during the day.
    Server guy email : "This is odd, very little was altered Jouni"

    so, as you can see, i have no idea what was the problem.
    Uphold Gentlemen driver standards. Police yourself!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •