Home
News
rFactor 2
rFactor 1
Forums
Contact
Company
Technology
Image Space Inc. YouTube rFactor 2 Twitter Image Space Inc. Google Plus rFactor 2 Facebook
NRT Servers
Try or Buy rFactor 2
$43.99/84.99 Windows Only PCDL
Download rFactor 2 Demo Now!

NOTICE Notice: This is an old thread and information may be out of date. The last post was 1414 days ago. Please consider making a new thread.
Results 1 to 10 of 10

Thread: Matching real steer rotation

  1. #1
    monkeygrinder's Avatar
     

    Newer Member
    Dec 2010
    Location
    Genova, Italy, Italy

    [SOLVED] Matching real steer rotation

    Hi everybody, maybe this is a question that has been already answered a million times before, but I'm really struggling to make my Logitech DFGT rotation match with the onscreen wheel.
    It looks like the Megane Eurocup has a 270 of rotation approx, deduction based on what I see in the cockpit view. I have set my wheel max rotation in Logitech profiler to 270 and so I did in the "Controller.ini" line "Steering Wheel Range".
    Now centered and "all rotated" positions are perfectly matching but I can't make the wheel rotation to be completely linear. I tried to set "Digital Steering Rate" to both sides of the slider, from 10% (Why no 0%?) to 100%, but none of these settings worked.
    The wheel turns in "different non-linear ways".
    Where am I wrong?
    Last edited by monkeygrinder; 12-11-10 at 05:54 AM.

  2. #2
    MystaMagoo's Avatar

     PC Specification 

    Registered
    Oct 2010
    Don't understand what your trying to achieve?

    You have done exactly what's needed for the wheels to match.

    The in game wheel is just 'visual',why do you want to see 2 wheels?

  3. #3
    V6_'s Avatar

     PC Specification 

    Registered
    Oct 2010
    Location
    New York
    Put your steering sensitivity to 50%, I've done that before :P

  4. #4
    Gonzo's Avatar

     rFactor 2 Validated PC Specification 

    Location
    Germany, Essen
    Knowledgeable member
    hmmm, correct controller.ini?

    try creating a new profile
    Set degree in logitech software
    set degree in controller.ini
    set speed sensitive steering to lowest possible value
    also set sensitivity to max or min (dont know).

  5. #5
    monkeygrinder's Avatar
     

    Newer Member
    Dec 2010
    Location
    Genova, Italy, Italy
    Quote Originally Posted by MystaMagoo View Post
    Don't understand what your trying to achieve?

    You have done exactly what's needed for the wheels to match.

    The in game wheel is just 'visual',why do you want to see 2 wheels?
    I'll try to be more specific: When the real wheel is at 0 degs, the cockpit wheel is at 0 degs. (Oh, well, ehr.. Of course) When the real wheel is at 135 degs (full turn) the cockpit wheel is at 135 degs. BUT when the real wheel is at 90 degs, the cockpit wheel is at (approx) 110 degrees.
    As I said before, I can't manage to get a real correspondance between the two wheels, because (in different ways) I always end up with the cockpit wheel kinda slowing down the turning speed the more it gets closer to the steering lock.
    I hope I've been clear enough, I'm sorry but english is not my mother tongue, so I might have maybe said something that wasn't easy to understand.

  6. #6
    monkeygrinder's Avatar
     

    Newer Member
    Dec 2010
    Location
    Genova, Italy, Italy
    Double post, sorry!

  7. #7
    monkeygrinder's Avatar
     

    Newer Member
    Dec 2010
    Location
    Genova, Italy, Italy
    Quote Originally Posted by Gonzo View Post
    hmmm, correct controller.ini?

    try creating a new profile
    Set degree in logitech software
    set degree in controller.ini
    set speed sensitive steering to lowest possible value
    also set sensitivity to max or min (dont know).
    I'll try, but the controller.ini, apart from the modification mentioned earlier, is clean, speed sensitive steering is at "0", and I've tried both 10% and 100% for sensitivity.
    Hell knows why there is no "0%" in the rates section.

  8. #8
    monkeygrinder's Avatar
     

    Newer Member
    Dec 2010
    Location
    Genova, Italy, Italy
    Quote Originally Posted by V6_ View Post
    Put your steering sensitivity to 50%, I've done that before :P
    To be honest, it was the first setting I've been racing with. But it was also inaccurate too. I'm starting to think that it might be a "Megane-related issue", but I can't check how other cars behave because I'm fairly drunk and I'm in bed! :D

  9. #9
    monkeygrinder's Avatar
     

    Newer Member
    Dec 2010
    Location
    Genova, Italy, Italy
    Quote Originally Posted by V6_ View Post
    Put your steering sensitivity to 50%, I've done that before :P
    You meant sensitivity, not steering rate!
    My sensitivity settings were at 90%, as soon as I got them to 50% everything went fine!
    Kudos, thank you for the hint!

  10. #10
    Hunt's Avatar

     PC Specification 

    New Member
    Dec 2010
    You make the wheel more linear by adjusting the range (degrees of rotation) within the Logitech software, the on-screen wheel does not have to correlate to the physical wheel at all. Speed sensitivity should be what ever suits you and adjusted lastly, X axis should be at 50% to start and adjust slightly as required. Try reducing the overall range of the physical wheel!.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •