Home
News
rFactor 2
rFactor 1
Forums
Contact
Company
Technology
Image Space Inc. YouTube rFactor 2 Twitter Image Space Inc. Google Plus rFactor 2 Facebook
Tracks
Try or Buy rFactor 2
$43.99/84.99 Windows Only PCDL
Download rFactor 2 Demo Now!

NOTICE Notice: This is an old thread and information may be out of date. The last post was 1017 days ago. Please consider making a new thread.
Results 1 to 11 of 11

Thread: Logitech DFGT Wheel with rFactor 2 Beta?

  1. #1
    nickbalti's Avatar

     rFactor 2 Validated LiveRacers Driver Page 

    Registered
    Jan 2012
    Location
    North Wales, UK

    Logitech DFGT Wheel with rFactor 2 Beta?

    rFactor 2 Beta detects my wheel fine, and even though a few of the mappings are a bit random I'm not that fussed.

    One of my biggest problem is the fact that my FBB is stupidly over the top, I go to break to a stop at about 5mph and I can feel my humerus about to snap!

    Secondly, and probably more importantly, is that when I go to turn left or right I have to turn my wheel around 3/4 times just for it to happen. I have tried different settings but can't master it. Any ideas?

  2. #2
    richiespeed13's Avatar

     rFactor 2 Validated PC Specification 

    Registered
    Oct 2010
    Location
    London
    This is very odd mate, I have a DFGT linked to G27 pedals via bodnar cable, and I have no issues whatsoever.

    I hope you get it fixed soon though.
    Live Fast, Die Young.
    Check out my YouTube!

  3. #3
    patryksok.'s Avatar

     rFactor 2 Validated 

    Registered
    Oct 2010
    I have no problems with my DFGT too. You have all deadzones to 0? And sensitivity to 100?

  4. #4
    nickbalti's Avatar

     rFactor 2 Validated LiveRacers Driver Page 

    Registered
    Jan 2012
    Location
    North Wales, UK
    Yep, deadzones at 0 and I've even tried sensitivity to 100.

    Here are some screenshots -

    These are the settings.


    This is the actual wheel turned to the right 1/4 turn.


    This is the actual wheel turned to the right 1/2 turn.

  5. #5
    nivam's Avatar
     

    New Member
    Jan 2012
    What is the "(200)" I see next to 900 in the steering wheel range option? I have DFGT detected ok and it shows only the 900 value!

  6. #6
    nickbalti's Avatar

     rFactor 2 Validated LiveRacers Driver Page 

    Registered
    Jan 2012
    Location
    North Wales, UK
    I'm not sure mate

    And I changed it to 900, the vehicle had it set to 480. The higher the number the better it gets, but even at the highest (1440) it's still not great. I wonder if its only treating it was 200 degrees.

  7. #7
    patryksok.'s Avatar

     rFactor 2 Validated 

    Registered
    Oct 2010
    nickbalti, change Sesitivity from 200 to 100, and set 900 deegrees in Logitech Profiler. And enable Vehicle set

  8. #8
    nickbalti's Avatar

     rFactor 2 Validated LiveRacers Driver Page 

    Registered
    Jan 2012
    Location
    North Wales, UK
    Thank you, I have noticed a slight improvement

    Now, does anyone know how to lower the FBB! It's honestly killing brain cells by the second!

  9. #9
    kmw's Avatar

     PC Specification 

    Registered
    Jan 2012
    Location
    Shropshire, UK
    Quote Originally Posted by nickbalti View Post
    Thank you, I have noticed a slight improvement

    Now, does anyone know how to lower the FBB! It's honestly killing brain cells by the second!
    This doesn't make sense. I have the DFGT and have not had these problems. My wheel turns almost exactly the same as the in game wheel. First, how high is your FFb set in the Logitech Profiler software? (I have mine deactivated - i.e. Use special FFB device settings is unticked). I have Special steering wheel settings' ticked and set at 270 at the moment, but still experimenting with that. And 'Use special game settings' ticked, plus 'allow game to adjust settings' is ticked. Try these first and see if it helps.
    Last edited by kmw; 01-12-12 at 11:09 AM.

  10. #10
    Big Takeover's Avatar
     

    New Member
    Jan 2012
    I was having the same problem yesterday with my DFGT. It also corresponded with the handling of the cars mysteriously going off.... it just didn't feel the same.

    I found the problem was the steering assist in the difficulty settings somehow got turned on to "low". I turned it off, and the 1:1 steering and all the feeling came back.

  11. #11
    patryksok.'s Avatar

     rFactor 2 Validated 

    Registered
    Oct 2010
    Quote Originally Posted by nickbalti View Post
    Thank you, I have noticed a slight improvement
    Turn off all aids.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •