Home
News
rFactor 2
rFactor 1
Forums
Contact
Company
Technology
Image Space Inc. YouTube rFactor 2 Twitter Image Space Inc. Google Plus rFactor 2 Facebook
Mediafire
Try or Buy rFactor 2
$43.99/84.99 Windows Only PCDL
Download rFactor 2 Demo Now!

NOTICE Notice: This is an old thread and information may be out of date. The last post was 1421 days ago. Please consider making a new thread.
Results 1 to 6 of 6

  Click here to go to the first staff post in this thread.   Thread: Keyboard Not Working

  1. #1
    vhpd085's Avatar

     PC Specification 

    New Member
    Oct 2010

    Keyboard Not Working

    Would anyone have any ideas why my keyboard will not work in rfactor when trying to create a player name or save a controller set up.

    I've recently moved over to a new Win 7(64Bit) PC and have two new rFactor installs, one I've put in “C:\rFactor installs\rFactor” the other in “C:\Program Files(x86)\rFactor”

    I've double checked the BIOS settings, tried a PS2 and USB keyboard, and made sure I'm running as Administrator. It works fine in an other app I open and I can edit the plr files no problem, but when it comes to naming a new player or to save a controller set up – nothing. Have I missed something?

    (I seem to remember having this problem once, a hundred years ago, with GPL !!)

  2. #2
    jgmonty's Avatar
     

    Newer Member
    Oct 2010
    Hi, sounds like a file(s) security issue i.e. File(s) are flagged as read-only. When you are using rfactor on Win7, make sure you have full admin access, not just using an admin account. If you are have problems running rfactor, right-click the rfactor.exe and select "Run As Administrator..."

    In Vista, turing off UAC (user access control) usually does the trick. In Win7, I don't believe the UAC can be turned off completely, but there will be a slider to minimise the security level. As modifying the UAC effects your overall PC security, use with discretion (last resort)...

    I have found that not using the default install path "c:\program files\..." is preferred. Personally, I only ever install system type applications to "c:\program files\...", certainly never games.

    Hope this helps.

  3. #3
    Jeffrey Rietveld's Avatar

     PC Specification 

    Registered
    Oct 2010
    It's a bug.

  4. #4
    vhpd085's Avatar

     PC Specification 

    New Member
    Oct 2010
    now the keyboard has started to work in one of my rFactor installs, but not the other

  5.   This is the last staff post in this thread.   #5
    Tim Wheatley's Avatar ISI Staff

     rFactor 2 Validated PC Specification @timwheatley1979 YouTube Channel Twitch/Streaming Channel Photo/Screenshot sharing profile 

    Location
    USA (Central)
    I think there is probably something open behind rFactor back in Windows, maybe a security question and your keyboard is working on that. Try running rFactor in Window mode and see if you can see something else open.

  6. #6
    vhpd085's Avatar

     PC Specification 

    New Member
    Oct 2010
    Well I've been away working for three days and have come back to find everything working, so I'm none the wiser ! It seems to have fixed itself. But thanks very much everyone for all the help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •